- #!/usr/bin/make -f
- # Sample debian/rules that uses debhelper.
- # This file is public domain software, originally written by Joey Hess.
-
- # Uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
-
- # This is the debhelper compatibility version to use.
- export DH_COMPAT=2
- DESTDIR=`pwd`/debian/`dh_listpackages`
-
- build: build-stamp
- build-stamp:
- dh_testdir
-
- # Add here commands to compile the package.
- #$(MAKE)
-
- touch build-stamp
-
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- #$(MAKE) clean
- #-$(MAKE) distclean
-
- dh_clean
-
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/<packagename>
- #$(MAKE) prefix=`pwd`/debian/`dh_listpackages` install
-
- -mkdir -p $(DESTDIR)/usr/bin
- -mkdir -p $(DESTDIR)/usr/sbin
- install -s src/r01.1/bin.linux52x86/p4 $(DESTDIR)/usr/bin
- install -s src/r01.1/bin.linux52x86/p4web $(DESTDIR)/usr/bin
- install -s src/r01.1/bin.linux52x86/p4d $(DESTDIR)/usr/sbin
- install -s src/r01.1/bin.linux52x86/p4ftpd $(DESTDIR)/usr/sbin
-
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
-
- # Build architecture-dependent files here.
- binary-arch: build install
- dh_testversion 2
- dh_testdir
- dh_testroot
- # dh_installdebconf
- dh_installdocs
- dh_installexamples
- dh_installmenu
- # dh_installlogrotate
- # dh_installemacsen
- # dh_installpam
- # dh_installmime
- # dh_installinit
- dh_installcron
- dh_installmanpages
- dh_installinfo
- # dh_undocumented
- dh_installchangelogs
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- # You may want to make some executables suid here.
- # dh_suidregister
- # dh_makeshlibs
- dh_installdeb
- # dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install
# |
Change |
User |
Description |
Committed |
|
#3
|
1813 |
David Markley |
Default constructor for Env needed to set the properties object. |
23 years ago
|
|
#2
|
1649 |
David Markley |
First working version of the debian package for Perforce. |
23 years ago
|
|
#1
|
1648 |
David Markley |
Added debian packaging of Perforce. |
23 years ago
|
|