SDP-296

erikf
Closed
Fixed bug where updates to os_tweaks.sh dropped support for RHEL 6.5.

From email [tweaked]:

This worked in previous releases but now the logic and checks have
changed sufficiently to preclude the use of RH6.5.

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.9 (Santiago)

I added the section below to get the script to run.  As can be
seen, none of the checks will pass Redhat 6.5. and it ends in the
default/else clause. I assume the RH6.X is still supported?

Os_tweaks.sh logic:
===
[[ -r /etc/redhat-release ]] || bail "This is only tested on RHEL/CentOS."

if [[ -n "$(grep 'CentOS release 6' /etc/redhat-release)" ]]; then
   echo -e "Verified: Running on supported OS (CentOS 6)."
   CorrectValues[0]="no"
== BEGIN Added  Block ==
elif [[ -n "$(grep '(Santiago)' /etc/redhat-release)" ]]; then
   echo -e "Verified: Running on supported OS (CentOS 6)."
   CorrectValues[0]="no"
== END Added  Block ==
elif [[ -n "$(egrep '(Core|Maipo)' /etc/redhat-release)" ]]; then
   echo -e "Verified: Running on supported OS (CentOS 7)."
   CorrectValues[0]="0"
else
   bail "This is only tested on RHEL/CentOS 6 and 7."
fi
Status
Closed
Project
perforce-software-sdp
Severity
C
Reported By
erikf
Reported Date
Modified By
tom_tyler
Modified Date
Owned By
tom_tyler
Component
setup
Type
Bug