Change 14747

Deriving the p4ruby version from version strings generated by engtools.

For main/prep branches, the version string is: [YEAR].[REL].0.[BRANCH][CHANGELIST]. This should allow people to depend on something like '~> 2015.1.0.main' or '~> 2015.1.0.prep' for any prereleases we make to Rubygems.

For release branches, the version string is [YEAR].[REL].[CHANGELIST]. Then, you can just depend on '~> 2015.1' for production releases.

I may not automate prereleases directly into Rubygems (there will be a lot of them because of the p4api dependency).
1 edited 0 added 0 deleted
Tip: Use n and p to cycle through the changes.