Reworked the log rotation stuff in backup_functions.sh to make it cleaner and
handle the new log from recreate_offline_db.sh.
Modified recreate_offline_db.sh to add comments about a bad checkpoint. Also
made it create its own log file since it isn't doing a checkpoint. Removed the
log rotation for the same reason.
Moved the LOGFILE setting out to all of scripts to make it more obvious for future
scripts that you need to set that variable in your script so that it doesn't just
default to checkpoint.log.
Moved the functions in weekly_backup.sh and recreate_offline_db.sh into backup_functions.sh
where they belong for consistency.
Modified backup_functions.sh to use a consistent naming convention for all the
rotated log files rather than checkpoint.log being unique.
Replaced all back ticks with the newer bash $() method.
Removed all of the line wrapping since I am pretty sure that none of us are working on an
80 character terminal these days and it is easier to read this way.
Routine merge to dev from main using:
p4 merge -b perforce_software-sdp-dev
|#6||15778||tom_tyler||Routine Merge Down to dev from main.|
- Ensure backup scripts are run as the OSUSER (to prevent accidental running as root);
- in scripts where LOGFILE value is changed from the 'checkpoint.log' set by set_vars, ensure the new assignment is before check_dirs is called, otherwise errors could be written to the 'wrong' log
- in 'die()' - detect if running from terminal & also send output to stderr
Normalized P4INSTANCE to SDP_INSTANCE to get Unix/Windows
implementations in sync.
1. Things that interact with SDP in both Unix and Windows
environments shoudn't have to account for this obscure
SDP difference between Unix and Windows. (I came across
this doing CBD work).
2. The Windows and Unix scripts have different variable
names for defining the same concept, the SDP instance.
Unix uses P4INSTANCE, while Windows uses SDP_INSTANCE.
3. This instance tag, a data set identifier, is an SDP concept.
I prefer the SDP_INSTANCE name over P4INSTANCE, so I prpose
to normalize to SDP_INSTANCE.
4. The P4INSTANCE name makes it look like a setting that might be
recognized by the p4d itself, which it is not. (There are other
such things such as P4SERVER that could perhaps be renamed as
a separate task; but I'm not sure we want to totally disallow
the P4 prefix for variable names. It looks too right to be wrong
in same cases, like P4BIN and P4DBIN. That's a discussion for
another day, outside the scope of this task).
* Fixed a bug in the Windows 2013.3 upgrade script that
was referencing undefined P4INSTANCE, as the Windows
environment defined only SDP_INSTANCE.
* Had P4INSTANCE been removed completely, this change would
likely cause trouble for users doing updates for existing
SDP installations. So, though it involves slight technical debt,
I opted to keep a redundant definition of P4INSTANCE
in p4_vars.template, with comments indicating SDP_INSTANCE should be
used in favor of P4INSTANCE, with a warning that P4INSTANCE
may go away in a future release. This should avoid unnecessary
* In mkdirs.sh, the varialbe name was INSTANCE rather than
SDP_INSTANCE. I changed that as well. That required manual
change rather than sub/replace to avoid corrupting other similar
varialbe names (e.g. MASTERINSTANCE).
This is a trivial change technically (a substitute/replace, plus
tweaks in p4_vars.template), but impacts many files.
Updated copyright date to 2015
Updated shell scripts to require an instance parameter to eliminate the need
for calling p4master_run. Python and Perl still need it since you have to set the
environment for them to run in.
Incorporated comments from reviewers. Left the . instead of source as that seems
more common in the field and has the same functionality.
|#2||11463||russell_jackson||Updated dev to prepare for Summit agreed changes.|
|#1||10148||tom_tyler||Promoted the Perforce Server Deployment Package to The Workshop.|