Prepared patch SDP/MultiArch/2018.1/23583.p2
* In README, moved 'Supported Open Source Software' section
to the top of the page, to make Support position more visible.
* Copyright updated to 2019.
* Cleanup of excess script recreate_db_sync_replica.sh
* Re-removal of previously deleted script recreate_db_checkpoint.sh,
and corresponding removal from test suite.
* This patch tarball will also contain some Docker test suite updates
already staged in main.
By-passing review to trigger an automated test.
Eliminated unnecessary removal of live rdb.lbr file.
The rdb.lbr from was being removed duing the scripts that reset
a replica using offline databases. The rdb.lbr file is not
regenerated from a checkpoint, and is not affected in the process
of regneration from a checkpoint, and thus should not be removed
in checkpoint-related processing.
Removing it was functionally mostly harmless, as the rdb.lbr
file gets regenerated and update as needed by user activity,
and also by p4verify.sh. However, removing it unnecesarily
caused unnecessary delay in getting archive files sync'd.
The processing in switch_db_files() in backup_functions.sh
(for the UNIX/Linux implementation) expects the rdb.lbr file
to exist prior to the db swap.
Changed rsync commands to avoid using compression when transferring
checkpoints, which are already compressed.
Fixed logging issue where log was truncated in mid-script.
Additional rm commands to make sure that we cleaned up both P4ROOT and OFFLINE_DB.
A customer indicated that the save directory was not cleaned up, so I just changed
it to clean up both directories.
Change the SDP so that root and offline_db can be on different volumes and still accomplish
a fast database recovery using recreate_db_checkpoint.sh and recreate_db_sync_replica.sh.
This is done by switching the links now rather than moving the db files.
Drop JOURNALNUM from the rotated log names because it forces you to wait to rotate
the prior logs until you get the journal number and creates a problem where the error
that you couldn't get the journal number ends up at the end of the previous days log
file, and that is what gets email out. That causes confusion for the person trying
to see what the error is.
Moved all rotate_last_run_logs up to the point right after we set the environment.
|#5||20937||russell_jackson||Added check to exit if we are not on a replica server.|
Approved and committed, but I believe that the shared data setting is always set to false on the master and we should look at fixing that in another change.
Enhanced p4login again.
Default behavior with no arguments gives the desired results.
For example, if run on a master, we login on the super user P4USER to
P4PORT. If run on a replica/edge and auth.id is set, we login P4USER
to the P4TARGET port of the replica.
All other login functionality, such as logging in the replication
service user on a replica, logging in supplemental automation users,
is now accessed via new flags.
A usage message is now available via '-h' and '-man' options. The
new synopsys is:
p4login [<instance>] [-p <port> | -service] [-automation] [-all]
The <instance> parameter is the only non-flag positional parameter,
and can be ommitted if SDP_INSTANCE is already defined (as is typical
when called by scripts).
With this change, several other scripts calling either the 'p4login'
script or 'p4 login' commands were normalized to call p4login as
appropriate given the new usage.
Reviewer Note: Review p4login first, then other files. Most changes
are in p4login.
In other scripts callling p4login, calls similar to:
$P4BIN -u $P4USER -p $P4PORT login < /path/to/pwd
are replaced with: $P4CBIN/p4login
In other scritps calling p4login, calls similar to:
$P4BIN -p $P4MASTERPORT login < /path/to/pwd
are replaced with: $P4CBIN/p4login -p $P4MASTERPORT
Note that, if auth.id is set, calling 'p4login' actually has the
same behavior as 'p4login -p $P4MASTERPORT', since p4login
called on a replica with auth.id set will just login to the master
Depending on intent, sometimes $P4BIN/p4login -service
== Misc Cleanup ==
In doing the cleanup:
* Fixed a hard-coding-to-instance-1 bug in broker_rotate.sh.
* Fixed an inconsistency in recreate_db_sync_replica.sh, where
it did just a regular login rather than a login -a as done in other
places for (for compatibility with some multi-interface NIC card
== p4login Call Normalization ==
Code cleanup was done to normalize calls to p4login, such that:
1) the call starts with $P4CBIN/p4login (not the hard-coded path),
and 2) logic to redirect sdtout/stderr to /dev/null was removed,
since it's not necessary with p4login. (And if p4login ever
does generate any unwanted output, we only fix it in one place).
== Tweak to instance_vars.template ==
This change includes a tweak to set P4MASTERPORT dynamically
on a replica to ensure the value precisely matches P4TARGET
for the given replica. This will reduce a source of problems
when SSL is used, as it is particularly sensitive to the precise
P4PORT values used, and will also help for environments which
have not yet set auth.id. If the port cannot be determined
dynamically, we fall back to the old logic using the assigned
== Tweak to SDP_ALWAYS_LOGIN behavior ==
This used to default to 1, now it defaults to 0. At this
point we should no longer need to force logins, and in fact
doing so can get into a 'p4 login' hang situation with
auth.id set. Best to avoid unnecessary logins if we
already have a valid ticket. (I think the need to force a
login may have gone away with p4d patches).
== Obsolete Script ==
With this change, svclogin.sh is now obsolete. All it was doing
was a few redundant 'p4 login' commands followed by a call to
== Testing ==
Our test suite doesn't fully cover this change, so additional
manual testing was done in the Battle School lab environment.
Per discussion: s/checkpoints.rep/journals.rep/g
This directory name changed, used in the journalPrefix configurable, is
intended to clarify that the should be targeted to for a FAST volume
for use with journalcopy, rather than the LARGE volume as would be
implied when using a directory with "checkpoints" in the name.
Moved password and users into the config directory to allow for instance specific
users and passwords. Ran into a case where two different teams were sharing the same
server hardware and needed this type of differentiation. Surprised that we haven't hit
Also defaulted mkdirs to use the numeric ports since this is the most common
Renamed weekly_sync_replica.sh to recreate_db_sync_replica to be consistent with
early rename of weekly_checkpoint.sh.
Changed crontab.replica to only run recreate_db_sync_replica when the master runs
Use the switch_db files function in the sync_replica script and added additional
logging and error checking.
Sorry Tom, I was wrong about being done. I just found this stuff while reviewing
my prior changes to recreate_db_checkpoint.sh and backup_functions.sh
Reworked the log rotation stuff in backup_functions.sh to make it cleaner and
handle the new log from recreate_offline_db.sh.
Modified recreate_offline_db.sh to add comments about a bad checkpoint. Also
made it create its own log file since it isn't doing a checkpoint. Removed the
log rotation for the same reason.
Moved the LOGFILE setting out to all of scripts to make it more obvious for future
scripts that you need to set that variable in your script so that it doesn't just
default to checkpoint.log.
Moved the functions in weekly_backup.sh and recreate_offline_db.sh into backup_functions.sh
where they belong for consistency.
Modified backup_functions.sh to use a consistent naming convention for all the
rotated log files rather than checkpoint.log being unique.
Replaced all back ticks with the newer bash $() method.
Removed all of the line wrapping since I am pretty sure that none of us are working on an
80 character terminal these days and it is easier to read this way.
Routine Merge Down to dev from main using:
p4 merge -b perforce_software-sdp-dev
Routine merge to dev from main using:
p4 merge -b perforce_software-sdp-dev
|#9||15778||tom_tyler||Routine Merge Down to dev from main.|
|#8||15701||tom_tyler||Routine merge down using 'p4 merge -b perforce_software-sdp-dev'.|
- Ensure backup scripts are run as the OSUSER (to prevent accidental running as root);
- in scripts where LOGFILE value is changed from the 'checkpoint.log' set by set_vars, ensure the new assignment is before check_dirs is called, otherwise errors could be written to the 'wrong' log
- in 'die()' - detect if running from terminal & also send output to stderr
Normalized P4INSTANCE to SDP_INSTANCE to get Unix/Windows
implementations in sync.
1. Things that interact with SDP in both Unix and Windows
environments shoudn't have to account for this obscure
SDP difference between Unix and Windows. (I came across
this doing CBD work).
2. The Windows and Unix scripts have different variable
names for defining the same concept, the SDP instance.
Unix uses P4INSTANCE, while Windows uses SDP_INSTANCE.
3. This instance tag, a data set identifier, is an SDP concept.
I prefer the SDP_INSTANCE name over P4INSTANCE, so I prpose
to normalize to SDP_INSTANCE.
4. The P4INSTANCE name makes it look like a setting that might be
recognized by the p4d itself, which it is not. (There are other
such things such as P4SERVER that could perhaps be renamed as
a separate task; but I'm not sure we want to totally disallow
the P4 prefix for variable names. It looks too right to be wrong
in same cases, like P4BIN and P4DBIN. That's a discussion for
another day, outside the scope of this task).
* Fixed a bug in the Windows 2013.3 upgrade script that
was referencing undefined P4INSTANCE, as the Windows
environment defined only SDP_INSTANCE.
* Had P4INSTANCE been removed completely, this change would
likely cause trouble for users doing updates for existing
SDP installations. So, though it involves slight technical debt,
I opted to keep a redundant definition of P4INSTANCE
in p4_vars.template, with comments indicating SDP_INSTANCE should be
used in favor of P4INSTANCE, with a warning that P4INSTANCE
may go away in a future release. This should avoid unnecessary
* In mkdirs.sh, the varialbe name was INSTANCE rather than
SDP_INSTANCE. I changed that as well. That required manual
change rather than sub/replace to avoid corrupting other similar
varialbe names (e.g. MASTERINSTANCE).
This is a trivial change technically (a substitute/replace, plus
tweaks in p4_vars.template), but impacts many files.
|#5||13904||tom_tyler||Routine merge down to dev from main.|
Updated copyright date to 2015
Updated shell scripts to require an instance parameter to eliminate the need
for calling p4master_run. Python and Perl still need it since you have to set the
environment for them to run in.
Incorporated comments from reviewers. Left the . instead of source as that seems
more common in the field and has the same functionality.
Routine merge down from 'main' to 'dev', resolved with
'p4 resolve -as'.
|#2||12028||tom_tyler||Refreshed SDP dev branch, merging down from main.|
|#1||10148||tom_tyler||Promoted the Perforce Server Deployment Package to The Workshop.|